Ich stehe gerade vor der Aufgabe für einen Kunden 3000 WooCommerce Gutscheine in sein Shop zu importieren und zuerst nach seinen vorgaben zu generieren. Und zwar durfte ich nur gewisse Zahlen, Buchstaben oder Sonderzeichen verwenden und musste mich an diese Vorgaben halten. Da ich kein Passwortgenerator kannte mit dem man diese Einschränkungen definieren konnte, musste ich selbst was coden, was ich dann auch mit PHP tat. Ich habe mir dann 4000 Gutscheincodes generiert und nun musste ich noch rausfinden, welche dieser Einträge doppelt vorhanden sind.

Also habe ich die Werte in Google Sheets importiert und dann habe ich einen coolen Trick gefunden, mit dem man doppelte Werte einfach markieren kann.

Unter ≪Format≫ -> ≪bedingte Formatierung≫ kann ich ein Popup öffnen wo ich dann nur den Zählenwenn Befehl eingeben muss

1
=ZÄHLENWENN($A$2:$B$18;A2)>1

Ihr müsst zuerst den Startpunkt und Endpunkt definieren, in dem ihr die Prüfung durchführen wollt. In diesem Beispiel war es zwischen A2 und B18 – dann jetzt ihr jetzt vor dem Buchstabe und den Zahlen je ein Dollarzeichen ein $ und schliesst dann den Befehl mit einem ; ab. Als nächstes müsst ihr nur noch das zu prüfende Feld definieren also das 1. A2. Und dann im letzten Schritt definiert ihr noch welche Wörter markiert werden sollen also ab wieviele wiederholungen. Ich will sie ja bei der 2. Wiederholung also ist >1 der Befehl.
Und dann ist der Befehl fertig und kann ausgeführt werden.

Die Prüfung erfolgt sofort und ihr seht nun schön markiert, welche Werte doppelt sind.

So einfach dieser Trick – wenn man weiss wie es geht!