Google Sheets – Doppelte Einträge finden und markieren

von | Dez 5, 2019 | Allgemein | 6 Kommentare

Ich stehe gerade vor der Aufgabe für einen Kunden 3000 WooCommerce Gutscheine in sein Shop zu importieren und zuerst nach seinen vorgaben zu generieren. Und zwar durfte ich nur gewisse Zahlen, Buchstaben oder Sonderzeichen verwenden und musste mich an diese Vorgaben halten. Da ich kein Passwortgenerator kannte mit dem man diese Einschränkungen definieren konnte, musste ich selbst was coden, was ich dann auch mit PHP tat. Ich habe mir dann 4000 Gutscheincodes generiert und nun musste ich noch rausfinden, welche dieser Einträge doppelt vorhanden sind.

Also habe ich die Werte in Google Sheets importiert und dann habe ich einen coolen Trick gefunden, mit dem man doppelte Werte einfach markieren kann.

Unter ≪Format≫ -> ≪bedingte Formatierung≫ kann ich ein Popup öffnen wo ich dann nur den Zählenwenn Befehl eingeben muss

1
=ZÄHLENWENN($A$2:$B$18;A2)>1

Ihr müsst zuerst den Startpunkt und Endpunkt definieren, in dem ihr die Prüfung durchführen wollt. In diesem Beispiel war es zwischen A2 und B18 – dann jetzt ihr jetzt vor dem Buchstabe und den Zahlen je ein Dollarzeichen ein $ und schliesst dann den Befehl mit einem ; ab. Als nächstes müsst ihr nur noch das zu prüfende Feld definieren also das 1. A2. Und dann im letzten Schritt definiert ihr noch welche Wörter markiert werden sollen also ab wieviele wiederholungen. Ich will sie ja bei der 2. Wiederholung also ist >1 der Befehl.
Und dann ist der Befehl fertig und kann ausgeführt werden.

Die Prüfung erfolgt sofort und ihr seht nun schön markiert, welche Werte doppelt sind.

So einfach dieser Trick – wenn man weiss wie es geht!

6 Kommentare

  1. Noah

    Die Lösung unterscheidet leider nicht zw. Groß- und Kleinschreibung bei Texten. 🙁

    Antworten
    • Eric-Oliver Mächler

      danke für die info – das wusste ich gar nicht – hab es damit nicht ausprobiert.

      Antworten
  2. Jasmina

    danke für deine Erklärungen. Hat bei mir super geklappt 🙂

    Antworten
    • Eric-Oliver Mächler

      das das freut mich 🙂

      Antworten
  3. Ingo

    Danke, das hat mir geholfen. Bitte erkläre mir noch, wie mal ALLE doppelten Einträge markieren kann, also nicht erst ab der 2. sondern alle, die gleich sind.
    Danke, Gruß, Ingo

    Antworten
    • Eric-Oliver Mächler

      hi ingo. ich verstehe gerade deine frage nicht. mit dem code findest du alle einträge die mehrfach vorhanden sind. egal ob 2 oder 3 oder noch mehrmals – siehe screenshot im link
      https://prnt.sc/-POma8LcZT9r

      Antworten

Einen Kommentar abschicken

Deine E-Mail-Adresse wird nicht veröffentlicht.